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Creating and Applying 

Cascading Style Sheets4

This chapter shows you how to use Cascading Style Sheets 
(CSS) to create and apply formatting. Cascading Style Sheets 

can save you a lot of tedious formatting time, especially if 
you format big Web sites.
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Topics: Creating and Applying 

Cascading Style Sheets

▪ Introducing Cascading Style Sheets

▪ Create an External Style Sheet

▪ Attach an External Style Sheet

▪ Customize an HTML Tag

▪ Create and Apply a Class Style Rule

▪ Create and Apply an ID Style Rule

▪ Page Properties



Cascading Style Sheets

▪ You can use cascading style sheets, or CSS, to 
exercise precise control over the appearance of 
your HTML documents.

▪ Style sheets can help you maintain a consistent 
look and feel throughout your Web site.
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▪ By regulating formatting controls to another 
sheet, you can free up your HTML document of 
repetitive coding to concentrate on the main 
elements and content that make you your page.
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Defining Style Sheets

▪ A style sheet is simply a separate text file with 
the .css file extension.

▪ Style sheets can also be internal, residing with an 
HTML document.

▪ A style sheet holds formatting codes, that 
control your Web page’s appearance.
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Defining Style Sheets (continuation)

▪ You can use style sheets to change the look of any 
Web page element, such as paragraphs, lists, 
background and more.

▪ Any time you want to apply formatting to an 
HTML document, you attach- or link – the style 
sheet to the page.
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Style Sheets Can Control Multiple 
Pages

▪ You can link every page in your Web site to a 
single sheet.  

▪ Any changes you make to the style sheet 
formatting are reflected in every HTML document 
linking to the sheet.

Source:  Simplified Creating Web Pages with HTML by Sherry Willard Kinkoph
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Style Sheets Can Control Multiple 
Pages  (continuation)

▪ By storing all the formatting information in one 
convenient spot, you can easily update appearance 
your site’s page in one whole swoop.

▪ This can be a real time-saver if your site consists 
of lots of pages.

Source:  Simplified Creating Web Pages with HTML by Sherry Willard Kinkoph
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Introduction to Cascading 
Style Sheet

▪ You can apply many different types of 
formatting to your Web pages with style sheets, 
also known as Cascading Style Sheets, or CSS.
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Format Text

▪ CSS enables you to create as many different style 
sheets as you want.

▪ You can then use them to format text by applying 
multiple formatting options at once, such as the 
font face, size and color.
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Create Global Web Page Styles

▪ You can create style sheets that apply to all of 
the pages in your Web site.

▪ You can then use the same style across your 
pages to make the formatting more consistent 
by saving the style in a file.

▪ You can make global changes by editing a style 
sheet to change the style across all of the pages 

that link to the external style sheet.
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Cascading Style Sheet Selectors

▪ Dreamweaver includes four different style 
selectors:.
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Internal Style Sheets

▪ A style sheet saved within the HTML code of a 
Web page is called an internal style sheet. 

▪ Internal style sheet rules apply only to the page in 
which they are included.
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External Style Sheets

▪ When you want your styles to apply to multiple 
pages on your Web site, you must save them in a 
separate file called an external style sheet.

▪ You can attach the same external style sheet to 
any or all of the pages in a Web site.
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Style Sheets and Web Browsers

▪ Some older Web browsers do not support style 
sheet standards, and different Web browses 
display style sheets differently.

▪ Always test pages that use style sheets on 
different browsers to ensure that content 
displays as you intend it to for all your visitors.
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▪ External style sheets enable you to define a set of 
style sheet rules and then apply them to many 
different pages – even pages on different Web 
sites.

▪ This enables you to keep a consistent 
appearance across many pages, and to 
streamline formatting and style updates.

Create an External Style Sheet



Create an External Style Sheet

1. Press <Ctrl> + <N> or from the Main Menu, 
select File->New  

2. Click New Document

3. Click CSS as the Document Type

4. Click Create

5. Press <Ctrl><S> or from the Main Menu, select 
File-> Save 

6. Type the file name - mystyle.css

7. Click Save

Create an External Style Sheet



Create an External Style Sheet
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Create an External Style Sheet
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How can I add more styles to an external 
style sheet?

▪ When you create any new style, you have the 
option of selecting an existing style sheet from the 
Rule Definition field in the New CSS Rule dialog 
box. To create a class style, see the section , 
“Create a Class Style.”

▪ To customize an HTML tag, see section, 
“Customize an HTML Tag”.

▪ When you define a new style in an external style, 
it is automatically added to the selected CSS file.

Create an External Style 
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Is it possible to add new styles later?

▪ Yes.  You can add styles to an external style sheet 
at any point during production, even months after 
the site was first published.

▪ In addition, you can make changes or additions 
while you work on any page that is currently 
attached to an external style sheet, and those 
styles will become available on any page where 
the style sheet is attached.

Create an External Style 
Sheet



▪ After you have created a style sheet, you can 
attach it to any or all of the Web pages in 
your site.

▪ You can even attach multiple style sheets to 
the same page.

▪ After you attach an external style sheet to a 
page, all the style rules in the style sheet 
become available, and you can apply them to 
elements on the page just as you would apply 
styles from an internal style sheet.

Attach an External Style Sheet



Attach an External Style Sheet
1. Open the page you want to attach the style sheet 

from the File Panel

2. Go to the CSS Designer tab

3. Click + in Sources panel

4. Select Attach Existing CSS File

5. Click on Browse 

6. Select the CSS File  - mystyle.css

7. Click OK

Attach an External Style Sheet 
(pg 220)



Attach an External Style Sheet
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Attach an External Style Sheet
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▪ You can customize the style that an existing 
HTML tag applies.  

▪ This enables you to apply special formatting 
whenever you use that tag to format text.

▪ This is a quick easy way to apply multiple style 
options with on HTML tag.

Customize an HTML Tag



1. Click on the CSS Designer tab

2. In the Source panel, select the external style 
sheet – mystyle.css

3. Click + Selectors

4. Type body for the body tag

Customize an HTML Tag

Add Style Rule for <body> Tag
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1. Select the body tag in Selectors Panel

2. Ensure the Show Set box in unchecked

3. In the Properties panel, select Background
button

4. For the background-color, click the arrow

5. Enter #B61B1D in the field

Customize an HTML Tag

Add Style Rule for <body> Tag
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1. Select the body tag in Selectors Panel

2. In the Properties panel, select Text button

3. For the color, enter #FFFFFF for white

4. For the font-family, select Cambria

5. For the font-weight, select normal

6. For the font-size, type 18px

7. For the text-align, select left-justified

Customize an HTML Tag

Add Style Rule for <body> Tag
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Customize an HTML Tag 

Customize an <body> Tag
1. Press <Ctrl><S> to save changes

2. Click on the style sheet to view the style rules added.
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1. Click on the CSS Designer tab

2. In the Source panel, select the style sheet

3. Click + Selectors

4. Type h1 for the Heading 1 tag

Customize an HTML Tag

Add Style Rule for <h1> Tag
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1. Select the h1 tag in Selectors Panel

2. In the Properties panel, select Text button

3. For the color, enter #FFFF00 for yellow

4. For the font-weight, select bold

5. For the font-size, type 40px

6. For the text-align, select center

Create a Class Style

Add Style Rule for <h1> Tag
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1. In the Document 
window, highlight 
the text

2. In the Properties 
Inspector, select 
heading 1 as the 
Format

3. From Main Menu 
Select File->Save All

Customize an HTML Tag

Apply the h1 tag to text element
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1. Click on the CSS Designer tab

2. In the Source panel, select the external style 
sheet- mystyle.css

3. Click + Selectors

4. Type h2 for the Heading 2 tag

Customize an HTML Tag

Add Style rule for <h2> Tag



Add Style rule for <h2> Tag
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1. Select the h1 tag in Selectors Panel

2. In the Properties panel, select Text button

3. For the color, enter #FFFF00 for yellow

4. For the font-weight, select bold

5. For the font-size, type 30 px

6. For the text-align, select center

Customize an HTML Tag

Add Style rule for <h2> Tag



Add Style rule for <h2> Tag
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1. In the Document 
window, highlight 
the text

2. In the Properties 
Inspector, select 
heading 2 as the 
Format

3. From Main Menu 
Select File->Save All

Customize an HTML Tag

Apply the h2 tag to text element
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1. Click on the CSS Designer tab

2. In the Source panel, select the external style 
sheet- mystyle.css

3. Click + Selectors

4. Type h5 for the Heading 5 tag

Customize an HTML Tag

Add Style rule for <h5> Tag
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1. Enter h5 tag in Selectors Panel

2. In the Properties panel, select Text button

3. For the color, enter #FFFFFF for white

4. For the font-weight, select normal

5. For the font-size, type 14 px

6. For the text-align, select center

Customize an HTML Tag

Add Style rule for <h5> Tag
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1. In the Document 
window, highlight 
the text

2. In the Properties 
Inspector, select 
heading 5 as the 
Format

3. From Main Menu 
Select File->Save All

Customize an HTML Tag
Apply the h5 tag to text element
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1. Click on the CSS Designer tab

2. In the Source panel, select the external style 
sheet- mystyle.css

3. Click + Selectors

4. Type a for the Anchor tag

Customize an HTML Tag

Add Style rule for <a> Anchor Tag
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1. Enter a tag in Selectors Panel

2. In the Properties panel, select Text button

3. For the color, enter #FFFF00 for yellow

Customize an HTML Tag

Add Style rule for <a> Tag
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Why should I redefine an HTML tag?

▪ When you redefine an HTML tag, you can apply 
more than one style to the tag.

▪ As a result, you only have to use one HTML tag 
instead of several to apply multiple formatting 
options.   

▪ For example, you can add center alignment to all 
of your H1 tags to control the alignment heading 
styles in one step.

Customize an HTML Tag



Does redefining an HTML tag change the 
format of any content that uses that tag?

▪ Yes. When you redefine an HTML tag, you 
change the tag’s formatting effect anywhere that 
you use the tag.

▪ You can limit the change to the page that you are 
working on, or you can include it in an external 
style sheet and apply to an entire site.

▪ If you do not want to alter the style of an existing 
HTML tag, then you should create class style
sheets instead of redefining HTML tags.

Customize an HTML Tag



▪ You can create class styles that can be used to 
format text and other elements on a Web page 
without affecting HTML tags.

▪ You can then apply those styles to any elements 
on your Web page, much like you would apply 
an HTML tag.

Create a Class Style Rule



1. Click on the CSS Designer tab

2. In the Source panel, select the external style 
sheet- mystyle.css

3. Click + Selectors

4. Type .emphasis for Class Rule

Add Class Style rule

NOTE:  A Class Rule always starts with a period

Create a Class Style Rule
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1. Select the .emphasis rule in Selectors Panel

2. In the Properties panel, select Text button

3. For the color, enter #FFFF00 for white

4. For the font-weight, select bold

5. For the font-size, type 20 px

6. For the text-align, select center

Add Class Style rule

Create a Class Style Rule
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What are the best uses of class styles?

▪ The class selector is great for creating styles that 
you may want to use multiple times on the same 
page

▪ Example:  A text style for captions or a 
formatting style that you can use to align 
elements on a page. Class styles can also be used 
in combination with other styles.

Create a Class Style Rule



Is it better to customize an HTML tag or 
create my own custom styles?

▪ One of the benefits of redefining existing HTML 
tags is that you can take advantage of recognized 
styles and hierarchies.

▪ This is especially true when heading tags. For 
example, if you change the way h1, h2, and h3 
tags appear, it is best to maintain their relative size 
difference, keeping h1 as the largest and using it 
to format the most important heading on the page.

Create a Class Style Rule



▪ You can apply a class style to any element on 
your Web page.

▪ Class styles allow you to change color, font, 
size, alignment, and other characteristics.

▪ You can use the same class style multiple 
times on the same page.

Apply a Class Style



1. In the Document 
window, highlight 
the text

2. In the Properties 
Inspector, from the 
Class pulldown select 
.emphasis 

3. From Main Menu 
Select File->Save All

Apply the class rule to element

1
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What are some other options that I can use 
to define the formatting for text with a 
style sheet?

▪ With style sheets, you can specify a numeric
value for font weight.

▪ This enables you to apply varying degrees of 
boldness, instead of just a single boldness setting 
as with HTML.

▪ You can also define type size in absolute units, 
such as pixels, points, picas, inches, centimeters, 
or relative units (i.e. ems, exes or percentage).

Apply a Class Style (pg 205)



Can I create as many style sheets as I 
want?

▪ Yes.  However, one of the goals of style sheets is 
to help you work more efficiently, so you should 
try to create styles that are as efficient as possible 
in the way they contain formatting options.

Apply a Class Style (pg 205)



▪ You can create ID style rule that can be used to 
format an element such as DIV layer a Web 
page 

▪ You can then apply the ID style rule to only one 
element on the Web page

Create an ID Style Rule



1. Click on the CSS Designer tab

2. In the Source panel, select the external style 
sheet- mystyle.css

3. Click + Selectors

4. Type #center-page for ID Rule

Add ID Style rule

NOTE:  An ID Rule always starts with a # (hash tag)

Create an ID Style Rule
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1. Select the #center-page rule in Selectors Panel

2. In the Properties panel, select Layout button

3. For the width, enter 800 px

4. For the height, enter auto

5. For the left margin, set the left to auto

6. For the right margin, set the left to auto

7. For padding, set 20px both left and right

Add an ID Style rule

Create an ID Style Rule
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▪ You can apply an ID style to only one element 
on your Web page.

▪ ID styles allows you to position content inside 
the body of the page or in a DIV layer.

Apply an ID Style Rule



1. In the Document window, select and highlight the 
entire page
NOTE: You can also select from File Menu, 
Edit->Select All

2. Click the Insert tab

3. Select Div

4. For ID rule, select center-page from the pulldown

Apply the ID rule to element

Apply an ID Style Rule



Apply the ID rule to element

1

2

Apply an ID Style Rule

3

4



1. Select the body  
tag rule in 
Selectors Panel

2. Select 
Background
button

3. For background-
color, set to 
#B61B1D

Edit an ID Style rule

Edit an ID Style Rule
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Edit a Tag Style rule

Edit a Tag Style Rule
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1. Select the body  
tag rule in 
Selectors Panel

2. Click on Show Set

3. Select 
Background
button

4. For background-
color, set to 
#000033
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▪ You can use Dreamweaver’s Page Properties 
dialog box to define page-wide styles, such as 
background colors, link style, and text options.

▪ When you define these options in the Page 
Properties dialog box, Dreamweaver 
automatically creates the corresponding styles 
and adds them to the Styles panel

Create Styles with Page 
Properties Dialog Box



Create Styles with Page Properties

1. CSS Designer tab, select the external style 
sheet- mystyle.css

2. Click the Page Properties button in the 
Property inspector.
Note: You can also select File->Page Properties

3. Click Appearance (CSS)

4. For the Background color, enter #000033

5. For Margins, enter 10 px for all sides

6. Click Apply

Create Styles with Page 
Properties Dialog Box



Create Styles with Page 
Properties Dialog Box
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Create Styles with Page Properties

7. Click Links (CSS)

8. Change the link colors
#FFFF00 for Link and Visited Links
#000033 for Rollover and Active Links

9. Click Apply

Create Styles with Page 
Properties Dialog Box



Create Styles with Page Properties

Create Styles with Page 
Properties Dialog Box
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